This post was originally published at Is Your App Ready to Meet Upcoming Google Play Requirements?

In December, 2017 some upcoming requirement changes for Android applications distributed through Google Play were announced on the Android Developers Blog. The first of those changes are happening on August 2018, so we’d like to help relay their message to help ensure you are ready.  Please note that these changes apply to both public and internal applications distributed using Google Play, so even if you only work on Android applications used internally at your organization, this message still applies to you.

Here are the details from the Android Developers Blog:

  • In the second half of 2018, Google Play will require that new apps and app updates target a recent Android API level (API level 26 Android 8.0 or higher). This will be required for new apps in August 2018, and for updates to existing apps in November 2018. This is to ensure apps are built on the latest APIs optimized for security and performance.
  • In August 2019, Play will require that new apps and app updates with native libraries provide 64-bit versions in addition to their 32-bit versions.
  • Additionally, in early 2018, Play will start adding a small amount of security metadata on top of each APK to further verify app authenticity. You do not need to take any action for this change.

For more detail and information behind these changes, be sure to check out: Improving app security and performance on Google Play for years to come

Google has also created some technical documentation to help enterprise developers migrate to API 26 from previous API levels.  That document can be found here: Migrating to API 26 for Android Enterprise

View article:

This post was originally published at Is Your App Ready to Meet Upcoming Google Play Requirements?