Android Version Distribution as of April 2014Starting in daily build 2014.2264, we are changing the minimum supported version on Android from 2.2 to 2.3.3. This means that if you do a device build with 2014.2264 (or later), your app will not run on a device whose version is below Android 2.3.3.

We are doing this for several reasons:

First, larger forces are at work. In particular, Google Play Services (not to be confused with Google Play Game Services) only works on 2.3. This is important because later this year, Google will make this service a prerequisite for displaying AdMob ads. Similarly, the Amazon Game Circle service requires upgrading the minimum version to 2.3.3.

Second, the numbers no longer make sense for us. The percentage of Android 2.2 devices has shrunken dramatically and is now barely above 1%.

Finally, Android is fragmented enough already. There’s a limit to how much hacking we can do to compensate for deficiencies of earlier versions of Android. Frankly, we’d rather spend our energy elsewhere.

If you must release on Android 2.2, we recommend you use an older daily build (prior to 2014.2264) or the last public release. All future daily builds and future releases will require Android 2.3.3 or higher.

Read More:

Changes in minimum OS version: Android 2.3.3