This post was originally published at Update on Corona, iOS 64-bit support and plugins

As I previously explained in Corona’s iOS 64-bit transition plan, Apple has imposed new app submission requirements that require 64-bit slices to be present in your application binaries.

These rules vary, depending on whether you are submitting a new app or updating an existing one:

  • Submissions of *new* apps are subject to the new rules starting Feb 1, 2015.
  • Updates to *existing* apps are subject to the new rules starting June 1, 2015.

Universal Build Availability

Last month, I mentioned that CoronaEnterprise and CoronaCards were already set up for the universal 32/64-bit requirements.

Today, starting in daily build 2015.2543, Corona SDK is now 32/64-bit universal. This is available immediately to Pro (and higher) subscribers.

For all other subscription tiers, we will be making an upcoming daily (beta) build available before the end of the month.

Finally, if have an existing app in the iTunes Store, you can continue to use the last public release (2014.2511) which is 32-bit until June 1, 2015. You only need to worry about the universal requirements for new apps.

Plugins

For backward compatibility purposes, all daily builds up to (and including) 2015.2534 will continue to have access to plugins that were previously available.

However, starting with 2015.2543, newer versions of Corona will only have access to the plugins listed here.

This is due to the fact that in order for your game/app to to satisfy Apple’s new requirements, plugins must also be 32/64-bit universal. In some cases, 3rd party partners could not/have not updated their plugin for various reasons. We are working with some of them to bring their updated plugins back as much as possible. We will also have all-new options soon.

Known Issues

The OpenSSL plugin works on device. However, there is an unresolved linker issue preventing its use in the Xcode Simulator.

View original: 

This post was originally published at Update on Corona, iOS 64-bit support and plugins